Join Early Retirement Today
Reply
 
Thread Tools Display Modes
Android app broken?
Old 02-02-2022, 01:26 PM   #1
Thinks s/he gets paid by the post
Sojourner's Avatar
 
Join Date: Jan 2012
Posts: 2,572
Android app broken?

I noticed this morning that the E-R.org app for Android isn't working properly on my Samsung tablet. When I open it, the splash screen appears for a few seconds and then I get two errors. "Network error, please try again later.", and "java.lang.RuntimeException: Register silent token failed". I have the latest version of the app from the Play Store. My tablet is running Android 11. All other apps seem to be working fine, so I don't think it's a problem with my tablet or network settings.
Sojourner is offline   Reply With Quote
Join the #1 Early Retirement and Financial Independence Forum Today - It's Totally Free!

Are you planning to be financially independent as early as possible so you can live life on your own terms? Discuss successful investing strategies, asset allocation models, tax strategies and other related topics in our online forum community. Our members range from young folks just starting their journey to financial independence, military retirees and even multimillionaires. No matter where you fit in you'll find that Early-Retirement.org is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with our members, see fewer ads, upload photographs, create a retirement blog, send private messages and so much, much more!

Old 02-02-2022, 02:33 PM   #2
Administrator
Gumby's Avatar
 
Join Date: Apr 2006
Posts: 22,781
Works fine on my Samsung Galaxy S8 phone (which uses the Android app). Maybe you can uninstall and reinstall the app?
__________________
Living an analog life in the Digital Age.
Gumby is offline   Reply With Quote
Old 02-02-2022, 02:38 PM   #3
Give me a museum and I'll fill it. (Picasso)
Give me a forum ...
MRG's Avatar
 
Join Date: Apr 2013
Posts: 11,074
I'm typing this on my android via the app. It seems to work.
MRG is offline   Reply With Quote
Old 02-02-2022, 03:16 PM   #4
Thinks s/he gets paid by the post
Sojourner's Avatar
 
Join Date: Jan 2012
Posts: 2,572
OK, thanks. Will try removing the app and reinstalling.
Sojourner is offline   Reply With Quote
Old 02-02-2022, 04:15 PM   #5
Thinks s/he gets paid by the post
Sojourner's Avatar
 
Join Date: Jan 2012
Posts: 2,572
Well, still no luck. I've uninstalled and reinstalled twice, and restarted the tablet. Still getting exactly the same errors as before. This is a Galaxy Tab S6 lite running Android 11. I guess I'll contact the developers via the Play Store if the problem persists.
Sojourner is offline   Reply With Quote
Old 02-03-2022, 11:45 AM   #6
Thinks s/he gets paid by the post
Sojourner's Avatar
 
Join Date: Jan 2012
Posts: 2,572
Finally figured out what the problem was. For some reason, all permissions had been disabled for the app in my settings. Once I enabled access to "storage" and "location", it started working properly. Not sure how those ever got disabled in the first place. Anyway, problem solved!
Sojourner is offline   Reply With Quote
Old 02-03-2022, 11:48 AM   #7
Administrator
Gumby's Avatar
 
Join Date: Apr 2006
Posts: 22,781
Thanks for reporting back.
__________________
Living an analog life in the Digital Age.
Gumby is offline   Reply With Quote
Old 02-14-2022, 05:42 PM   #8
Full time employment: Posting here.
Trooper's Avatar
 
Join Date: Dec 2012
Location: Chandler, AZ
Posts: 720
Quote:
Originally Posted by Sojourner View Post
Finally figured out what the problem was. For some reason, all permissions had been disabled for the app in my settings. Once I enabled access to "storage" and "location", it started working properly. Not sure how those ever got disabled in the first place. Anyway, problem solved!
Thanks Sojourner. Same thing happened to me and I used your fix above. All good now.
Trooper is offline   Reply With Quote
Old 03-25-2022, 12:39 PM   #9
Thinks s/he gets paid by the post
Cobra9777's Avatar
 
Join Date: Jul 2012
Location: Texas
Posts: 3,013
I just got a new phone, Google Pixel 6 running Android 12. I've been installing apps all day with no issues. The ER.org Android app installed OK. But opening it resulted in the exact same error messages that OP reported. I can't get past the splash page. I tried manually enabling the permissions as suggested. Still doesn't work. The app doesn't seem to want to run on this device.

Any suggestions?
__________________
Retired at 52 in July 2013. On to better things...
AA: 55% stock, 15% real estate, 27% bonds, 3% cash
WR: 2.7% SI: 2 pensions, some rental income, SS later
Cobra9777 is offline   Reply With Quote
Old 03-25-2022, 04:12 PM   #10
Thinks s/he gets paid by the post
Sojourner's Avatar
 
Join Date: Jan 2012
Posts: 2,572
Quote:
Originally Posted by Cobra9777 View Post
I just got a new phone, Google Pixel 6 running Android 12. I've been installing apps all day with no issues. The ER.org Android app installed OK. But opening it resulted in the exact same error messages that OP reported. I can't get past the splash page. I tried manually enabling the permissions as suggested. Still doesn't work. The app doesn't seem to want to run on this device.

Any suggestions?
The only suggestion I have would be to uninstall the ER.org app, restart your phone, and thenóbefore opening up the appógo into Settings and make sure "Storage" and "Location" permissions are enabled for the app. Then try starting the app.
Sojourner is offline   Reply With Quote
Old 03-25-2022, 04:31 PM   #11
Thinks s/he gets paid by the post
Cobra9777's Avatar
 
Join Date: Jul 2012
Location: Texas
Posts: 3,013
Quote:
Originally Posted by Sojourner View Post
The only suggestion I have would be to uninstall the ER.org app, restart your phone, and thenóbefore opening up the appógo into Settings and make sure "Storage" and "Location" permissions are enabled for the app. Then try starting the app.
Thanks. Just tried that. Still won't run. I get the splash screen and then the same error messages you posted.

It's working fine on my older phone.
__________________
Retired at 52 in July 2013. On to better things...
AA: 55% stock, 15% real estate, 27% bonds, 3% cash
WR: 2.7% SI: 2 pensions, some rental income, SS later
Cobra9777 is offline   Reply With Quote
Old 03-25-2022, 04:51 PM   #12
Thinks s/he gets paid by the post
Sojourner's Avatar
 
Join Date: Jan 2012
Posts: 2,572
Quote:
Originally Posted by Cobra9777 View Post
Thanks. Just tried that. Still won't run. I get the splash screen and then the same error messages you posted.

It's working fine on my older phone.
Hmmm. Maybe it's an Android 12 issue, then? Perhaps the app hasn't been updated for compatibility with 12.
Sojourner is offline   Reply With Quote
Old 03-25-2022, 04:55 PM   #13
Thinks s/he gets paid by the post
Cobra9777's Avatar
 
Join Date: Jul 2012
Location: Texas
Posts: 3,013
Quote:
Originally Posted by Sojourner View Post
Hmmm. Maybe it's an Android 12 issue, then? Perhaps the app hasn't been updated for compatibility with 12.
That's what I'm thinking.
__________________
Retired at 52 in July 2013. On to better things...
AA: 55% stock, 15% real estate, 27% bonds, 3% cash
WR: 2.7% SI: 2 pensions, some rental income, SS later
Cobra9777 is offline   Reply With Quote
Old 03-26-2022, 04:34 PM   #14
Thinks s/he gets paid by the post
Cobra9777's Avatar
 
Join Date: Jul 2012
Location: Texas
Posts: 3,013
Well, the app started working today. I never enabled the permissions. Just did a fresh install. Rebooted the phone before starting the app. Then after the reboot, it opened up fine. Still no permissions enabled. Evidently, they aren't required.
__________________
Retired at 52 in July 2013. On to better things...
AA: 55% stock, 15% real estate, 27% bonds, 3% cash
WR: 2.7% SI: 2 pensions, some rental income, SS later
Cobra9777 is offline   Reply With Quote
Old 03-26-2022, 04:43 PM   #15
Administrator
Gumby's Avatar
 
Join Date: Apr 2006
Posts: 22,781
Thanks for letting us know.
__________________
Living an analog life in the Digital Age.
Gumby is offline   Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Android App Goes to Youtube TromboneAl Forum Admin 3 09-22-2014 07:00 PM
Android app crashing MRG Forum Admin 19 07-09-2014 06:11 PM
Best Android News App: BBC News TromboneAl Other topics 1 04-14-2014 10:15 AM
Problem with Android App TromboneAl Forum Admin 2 12-31-2013 03:48 PM
DQOTD: How do I get the ER.org Android app to stop notifications? Midpack Other topics 3 12-09-2013 06:36 PM

» Quick Links

 
All times are GMT -6. The time now is 03:03 AM.
 
Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2024, vBulletin Solutions, Inc.