Double spacing between paragraphs in posts? New?

The 67.0 update caused Firefox to startup with a blank page. After trying a number of things that didn't work I had to "refresh" Firefox, setting it back to factory defaults. Then I had to download my add-ons again and reconfigure things back to where I had them. There were a few annoyances I had forgotten about like the search engine bar under the address bar when typing, and the double space thing here on this forum.
Now that the Firefox update has been mentioned a few times, it may explain other oddities I've seen. For example, a glitch in Schwab where the portfolio performance area appears, disappears, and tells me my session has expired.
 
Problem reappeared with Firefox 67.0 update.
Trying the about:config solution.

I just checked, I'm on 67.0, had not seen the problem reappear, so I checked, and my about:config still had 'false' for that "editor.use_div_for_default_newlines" entry.

So I guess it held through the update? Maybe the linux update process is slightly different?

-ERD50
 
Last edited:
I have Firefox 67.0 and had no issues with it on this site or other sites.

The 67.0 update did not break the line feed issue, but would only show blank pages when opened up. The only workable "fix" was to reset back to factory settings, which wiped out the line feed setting.

Thankfully, I remembered this old post and was able to track down the solution again.
 
This sort of issue seems to pop up occasionally at browser updates and over the past years has happened with Firefox, Chrome and IE/Edge. Changing the editor options is your settings is usually a good work around until the browser release has been patched.
 
Ok, discovered another thing you can do with Firefox, if you want to keep the WYSIWYG editor (meaning don't drop to the standard option in forum).
- go to about:config
- search for editor.use_div_for_default_newlines
- double-click the line to change it to false
Everything above is typed on a line, with enter key pressed at the end.
Say it:
No
Extra
Line
Breaks.

I registered for this forum to explicitly thank you for this post. I'm one of the moderators of another forum and after upgrading to an ESR version of Firefox, all my posts started having double spaces between paragraphs. Your suggestion fixed the problem. Thank you.

p.s. Fount this thread through a Google search when investigating a solution.

p.p.s. I am retired, but was not an "early retiree".
 
I registered for this forum to explicitly thank you for this post. I'm one of the moderators of another forum and after upgrading to an ESR version of Firefox, all my posts started having double spaces between paragraphs. Your suggestion fixed the problem. Thank you.

p.s. Fount this thread through a Google search when investigating a solution.

p.p.s. I am retired, but was not an "early retiree".
volosong, you are welcome.

There are a bunch of washed-up troubleshooters on board who are ready to post...
 
It's funny that I've found this message thread, while searching for a solution to the same problem.

See also my post here - where I was also self-testing various settings:
https://www.early-retirement.org/fo...doubles-newline-empty-line-breaks-107054.html

There seem to be two ways to fix it:
- Set editor.use_div_for_default_newlines to false (as also mentioned in this thread)
- End your text lines via Shift+Enter instead of Enter.

In my case I preferred to go with the 1st option.
 
In my version of Firefox (60.0) there's no "Composition" selection in Tools > Options > General tab. :confused:


omni

The "Composition" option is only for Mozilla's Thunderbird e-mail client. I know, it's confusing :).
 
Test line 1
Test line 2
Test line 3

Edit: Thank goodness for this thread.
 
Test line 1
Test line 2
Test line 3

Edit: Thank goodness for this thread.
Yes, pops up infrequently, so hard to remember the fix…
 
:greetings10:
Such a useful thread that keeps on giving!
 
Here we go again.


My firefox was just updated to 112.0.


And guess what? This disease came back. Argh! :facepalm::facepalm::facepalm:


I checked "about:config" and "editor.use_div_for_default_newlines" is still false.


Anyone else seeing this, and/or have a solution?
 
Here we go again.


My firefox was just updated to 112.0.


And guess what? This disease came back. Argh! :facepalm::facepalm::facepalm:


I checked "about:config" and "editor.use_div_for_default_newlines" is still false.


Anyone else seeing this, and/or have a solution?

Made me look. I'm on FF 112.0 on Linux/Xubuntu, have been for at least a few days. Had not noticed it. So here's an 'enter' for a new line/paragraph.
new line
new line

2x 'enter' for new spaced paragraph. I'll post now to see how it looks. (after post edit - seems OK?)

further edit: "I checked "about:config" and "editor.use_div_for_default_newlines" is still false." < mine is as well

-ERD50
 
OK. Killed Firefox and rebooted the Win 10 PC. Let's see what this looks like.


Line1
Line2
Line3 (newline follows this)


Line4 after newline
 
Windows 10 Pro and FF 112.0. Yep, the double spacing has returned.
 
this is a test
should be no double spacing
I will delete this shortly

----------------
I did the above and it looks OK. I have Win 10 and up to date. Have not removed it since it shows some of us are not affected.
 
Returned the config to "true". Let's see what happens.


Line 1
Line 2
Line 3 (with an extra newline after)


Line 4
 
That was disappointing. Returned it back to false.


Line 1
Line 2
Line 3 (with extra newline following)


Line 4


If this doesn't work, I'm going to wonder about the duckduckgo extension possibly poisoning Firefox.


Edit: obviously didn't work. I feel a bit SOL here.
 
So I added editor.use_div_for_default_newlines back to about:config.


Line 1
Line 2
Line 3 (newline follows)


Line 4


I give up.
 
This is my test.


I wonder what will happen.


It appears to be my issue also.
 
So I added editor.use_div_for_default_newlines back to about:config.


Line 1
Line 2
Line 3 (newline follows)


Line 4

Wait a minute - how are you getting the Line 1-3 following each other with no added line space? Maybe I'm misinterpreting what you meant by "newline"?

In the following, I'll use <Enter key hit here> to signify I actually hit the 'Enter' key. If I'm referring to the 'Enter' key, w/o actually hitting it, I'll just say 'Enter':

-----start after this line-----
I write this and then I hit 'Enter', and I'll be on the next line <Enter key hit here>
And now I'm here - no extra line space between the lines, like your Line 1-2-3 <Enter key hit here>
<Enter key hit here>
And that was two 'Enters'<Enter key hit here>
<Enter key hit here>
--------------------end--------------

So it would look like this:

I write this and then I hit 'Enter', and I'll be on the next line.
And now I'm here - no extra line space between the lines, like your Line 1-2-3.

And that was two 'Enters'

And now I'm done - ERD50
 

Latest posts

Back
Top Bottom